Site hangs for me

It’s not exactly that the whole site hangs, but I wasn’t sure how to describe it. I often get one of two issues:

  1. I click on sometime, say, a topic I want to read, and I just get a spinny thing until I give up and click on the top level menu or the hamburger menu or something.
  2. I’m reading a topic, but I don’t see all the posts. And at the bottom of the page I just see “placeholders”. If I get into the thread later, yeah, there was real content there that wouldn’t load for me.

I don’t have this problem with the other Discourse site I use, so it’s something about this site. Or about how this site interacts with my ISP, or my computer, or…?

Anyway, I wanted to report that I have this problem, and who knows, maybe get help resolving it.

This has happened to me too, but on my cell phone.

I get it on my phone as well as my laptop.

Not sure. Sounds like it’s probably something on my end. I haven’t seen this (though when opening multiple threads all at once I’ve been throttled by the software deliberately).

I doubt it’s the hardware, the server is so overpowered and the forum is the only site on the machine. And it’s sitting at like 99% idle all the time.
I doubt it’s my switch, but I’m going to check next time I go to the data center that it’s a gigabit switch and not just a 10/100. Again, pretty sure it’s a gigabit, and even if it’s not a 10/100 is likely way more than necessary currently.
Which leaves the software. I’ll mention it to my dev guy and see if he can do any rooting around, maybe find something in the logs.

Have you tried updating your browser?

Also, do you get the same hang-up if you use a different browser?

FWIW, I noticed that issue on occasion on the AO, and usually closing and reopening the browser seemed to help.

You mean, not using an obsolete version of the browser? Or something else?

fwiw, this has never once been an issue on the other Discourse chat site I frequent, and it’s a common issue on GoActuary, so my guess is it’s not my browser.

I’ve had no issues using Edge on desktop or Safari on phone.

Hmm, I’m using Chrome on desktops, and Firefox on my Android phone. I haven’t really paid attention to whether it is more reliable on one desktop (Windows) or the other (Mac) Both have somewhat out-of-date browsers for different reasons. The phone browser is likely up-to-date, but I can check that.

Things were hanging up for me a bit yesterday on my phone, but I figured it was just that I had bad service. I’ve never really noticed any other problems.

The weird thing is that it’s often the same topic that will hang for quite a while. I can shift to another topic and read it fine, but when I go back the first topic is still hanging.

So, the logs have been combed. There’s no errors related to anything like this. it looks like we’re serving as we’re supposed to.
How’s your wifi? Any chance it’s a bit light? I get the same problem you’re seeing on other sites when I’m on my ipad upstairs because the wifi’s not great.

Hmm, you know, it now occurs to me that i had the same problem on another site when I started to use it…i haven’t had it in a while. Maybe the software is bandwidth-intensive until it’s cached a lot of stuff?

My wifi is usually excellent, but i do get spotty interruptions sometimes.

Thanks for checking it out. I guess i just need to live with it.

Also, i love your new user name. RN.

well, I’m having trouble again. I’m trying to read this thread:

when I tried to get to it from the “someone replied to you” menu, it just hung. When I tried to go there from the category menu, I was able to read most of the thread, but the posts at the bottom hung. Repeatedly going in and out showed me more posts. Now, when I go there, it seems to think there are posts it can’t load below the post that I just made (which I suspect is actually the last one – since it’s 148, and in other places the system tells me there are 148 posts i there.)

I just went to another discourse forum and poked around, and everything was responsive. I did have issues with that board for a while after they converted over, so maybe Discourse needs to move more data in some circumstances than others? Still, I’ve been on-line all day, downloading big articles, streaming live meetings, etc., and haven’t had connectivity troubles with anything else.